suspicion that Fan chart is not working correctly

For notifying us of what you believe are bugs or errors in EViews.
Please ensure your copy of EViews is up-to-date before posting.

Moderators: EViews Gareth, EViews Moderator

QIO
Posts: 4
Joined: Sat Feb 27, 2021 11:26 am

suspicion that Fan chart is not working correctly

Postby QIO » Mon Apr 05, 2021 2:27 pm

hi everyone,
ive tried to post this as question in the model forum but no one seems to answer, so lets try it here; I am testing various ARIMAX auto-selected models and their applicability for producing benchmark models. For this I have also solved models via the stochastic option to produce fan charts (using simulation). To produce the forecast with standard error bounds one can simply add to the forecast trajectory (in the non panel worksheet) to the projected variable (see below)

Code: Select all

YMP_REPIHSG_ML_US_M_0M
YMP_REPIHSG_ML_US_M
YMP_REPIHSG_ML_US_M_0M+2*YMP_REPIHSG_ML_US_M_0S
YMP_REPIHSG_ML_US_M_0M+YMP_REPIHSG_ML_US_M_0S
YMP_REPIHSG_ML_US_M_0M-YMP_REPIHSG_ML_US_M_0S
YMP_REPIHSG_ML_US_M_0M-2*YMP_REPIHSG_ML_US_M_0S


Now this can be replicated within the simulated panel with calling for graph>mean plus SD bounds>1std.dev or 2std.dev
However, if I select mean plus SD bounds>Fan chart the outcome is something totally different, it seems that the process has become more like an additive Brownian motion (making variables go negative, something not possible since I am using log processes for the ARIMA specification)

Do I get something wrong on what the FAN element is doing when applying it to mean? When using median the elements look to be correct (see attached word doc for comparing the charts)
Best
M
ps: sorry, i was not able to paste the images directly into the forum
Attachments
Solving outside of panel model using stochastic solution.docx
(145.62 KiB) Downloaded 53 times

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 6 guests