Correct way to set up auto-update functionality ("Invalid XML was found.")

For tips, questions and general information about writing Add-ins, how to package them, and how to submit them to EViews for publication.

Moderators: EViews Gareth, EViews Moderator

CrisisStudent
Posts: 30
Joined: Mon Nov 16, 2020 10:52 am

Correct way to set up auto-update functionality ("Invalid XML was found.")

Postby CrisisStudent » Wed Apr 21, 2021 2:06 am

Hi all,

I have posted add-in on Eviews site, but did not realize the update does not function properly. There were initially some mistakes on my part, but even after fixing those I still get message "Invalid XML was found.", so I must be still missing something.

The fixed add-in package is attached, below is the instalation command and XML file. Could you help me with fixing it?

Thanks!
CrisisStudent

Code: Select all

addin(type="equation",menu="Specifiation(s) evaluation",proc="speceval",docs=".\documentation\specification_evaluation.pdf",desc="Performs evaluation of (forecasting properties of) equation(s) and prepares report summarizing the results.",url="https://github.com/CrisisStudent/SpecEval/blob/master/update_info.xml",version="1.0") ".\specification_evaluation.prg"



Code: Select all

<item>
<title>speceval</title>
<path>specification_evaluation.prg</path>
<version>1.0</version>
<description>Performs evaluation of (forecasting properties of) equation/VAR/identity object(s) and prepares report summarizing the results.</description>
<link>https://github.com/CrisisStudent/SpecEval/blob/master/Package/SpecEval.aipz</link>
<pubDate>4 Apr 2021</pubDate>
</item>

EViews Gareth
Fe ddaethom, fe welon, fe amcangyfrifon
Posts: 12945
Joined: Tue Sep 16, 2008 5:38 pm

Re: Correct way to set up auto-update functionality ("Invalid XML was found.")

Postby EViews Gareth » Wed Apr 21, 2021 6:46 am

The issue (and it is common with github) is that the address you're using isn't just the raw XML - the site has all the other github stuff around it.
Use this link instead:

Code: Select all

https://raw.githubusercontent.com/CrisisStudent/SpecEval/master/update_info.xml
Follow us on Twitter @IHSEViews

CrisisStudent
Posts: 30
Joined: Mon Nov 16, 2020 10:52 am

Re: Correct way to set up auto-update functionality ("Invalid XML was found.")

Postby CrisisStudent » Wed Apr 21, 2021 7:48 am

Thanks Gareth!

It helped, as now Eviews manages to check for the update. However I encounter problem when I confirm that I want to update the file. For the add-in mentioned above I get error
"SPECEVAL: Error encountered during install - Could not open file due to: unknown error."
. I also tried for other add-in and there I get
"COLORCODE: Could not retrieve AIPZ file"
.

This is after I have changed the path also in the update_info.xml file, which is now following:

Code: Select all

<item>
<title>speceval</title>
<path>specification_evaluation.prg</path>
<version>1.0</version>
<description>Performs evaluation of (forecasting properties of) equation/VAR/identity object(s) and prepares report summarizing the results.</description>
<link>https://raw.githubusercontent.com/CrisisStudent/SpecEval/master/Package/SpecEval.aipz</link>
<pubDate>4 Apr 2021</pubDate>
</item>

EViews Gareth
Fe ddaethom, fe welon, fe amcangyfrifon
Posts: 12945
Joined: Tue Sep 16, 2008 5:38 pm

Re: Correct way to set up auto-update functionality ("Invalid XML was found.")

Postby EViews Gareth » Wed Apr 21, 2021 8:08 am

Same issue. Your XML file:

Code: Select all

<item>
<title>speceval</title>
<path>specification_evaluation.prg</path>
<version>1.0</version>
<description>Performs evaluation of (forecasting properties of) equation/VAR/identity object(s) and prepares report summarizing the results.</description>
<link>https://github.com/CrisisStudent/SpecEval/blob/master/Package/SpecEval.aipz</link>
<pubDate>4 Apr 2021</pubDate>
</item>

Has a link which is the generic github link - you'll need to replace the link with the raw.
Follow us on Twitter @IHSEViews

CrisisStudent
Posts: 30
Joined: Mon Nov 16, 2020 10:52 am

Re: Correct way to set up auto-update functionality ("Invalid XML was found.")

Postby CrisisStudent » Wed Apr 21, 2021 8:15 am

That's what I thought, but I already fixed that (see code in my last reply).

Also, when I use that link, the installation package downloads and runs correctly.

EViews Gareth
Fe ddaethom, fe welon, fe amcangyfrifon
Posts: 12945
Joined: Tue Sep 16, 2008 5:38 pm

Re: Correct way to set up auto-update functionality ("Invalid XML was found.")

Postby EViews Gareth » Wed Apr 21, 2021 9:18 am

The XML file right now doesn't have the raw part.
https://raw.githubusercontent.com/Crisi ... e_info.xml
Follow us on Twitter @IHSEViews

CrisisStudent
Posts: 30
Joined: Mon Nov 16, 2020 10:52 am

Re: Correct way to set up auto-update functionality ("Invalid XML was found.")

Postby CrisisStudent » Wed Apr 21, 2021 12:36 pm

Ah, yeah, I did no push online, of course. When I fixed this then the update for the other two add-ins works. But for SpecEval I get message that Installation failed (it works when I run the link directly). Any way to check what is going on? All the updated files are now on the GitHub site.

EViews Gareth
Fe ddaethom, fe welon, fe amcangyfrifon
Posts: 12945
Joined: Tue Sep 16, 2008 5:38 pm

Re: Correct way to set up auto-update functionality ("Invalid XML was found.")

Postby EViews Gareth » Wed Apr 21, 2021 12:41 pm

Just tried it, and it worked for me.
Follow us on Twitter @IHSEViews

CrisisStudent
Posts: 30
Joined: Mon Nov 16, 2020 10:52 am

Re: Correct way to set up auto-update functionality ("Invalid XML was found.")

Postby CrisisStudent » Wed Apr 21, 2021 11:42 pm

Well, after restart it worked for me too. Moody computers, I guess. :shock:

Thanks a lot for all your help!


Return to “Add-in Writing area”

Who is online

Users browsing this forum: No registered users and 1 guest