REGCOMPONENTS issue

For questions regarding installation and registration of EViews.

Moderators: EViews Gareth, EViews Jason, EViews Steve, EViews Moderator

wilshire
Posts: 40
Joined: Fri Jan 07, 2011 12:49 pm

REGCOMPONENTS issue

Postby wilshire » Wed Mar 11, 2020 11:22 am

I am looking to do a TRAMO-SEATS seasonal adjustment in Eviews, but get the following error:

“EViews 32-bit Layer has not be properly registered. Please run REGCOMPONENTS to register this component, then try again.”

Running REGCOMPONENTS to register the EViews 32-bit Layer requires admin permission.

Please advise,

EViews Steve
EViews Developer
Posts: 654
Joined: Tue Sep 16, 2008 3:00 pm
Location: Irvine, CA

Re: REGCOMPONENTS issue

Postby EViews Steve » Wed Mar 11, 2020 11:51 am

The short answer is that you will need to register the EViews32COM.exe program via our REGCOMPONENTS dialog successfully before you can use TRAMO/SEATS. And to do that, you'll need to have local admin rights (or someone with local admin rights to do this for you).

To see if you have this, shut EViews down, then right-click the EViews shortcut and select "Run as administrator". If your account has local admin rights, you'll be presented with a UAC dialog that asks for your permission to run EViews with the admin rights enabled. If you don't have local admin rights, then you'll be presented with a small login dialog that allows you to enter the credentials (username & password) of someone that does have local admin rights. If you see this dialog, I would suggest you find the person that installed EViews onto your machine to have them enter their credentials into this dialog. Once logged in, re-run the REGCOMPONENTS command to bring up the dialog and then click the "Yes (All)" button to re-register everything. Once you see the success message, you'll be able to use TRAMO/SEATS, even if you restart EViews without the "Run as administrator".

Steve

jfgeli
Posts: 72
Joined: Fri Jan 30, 2009 6:29 pm

Re: REGCOMPONENTS issue

Postby jfgeli » Mon Nov 30, 2020 2:35 am

Hello, I have a different issue but also related with REGCOM.

I got a new pc at my new job. I don´t have admin rights. A colleague from IT tried to install Eviews (he has admin rights).

However, the COM Excel add-in was not properly registered. Even if we try with the commnand REGCOM command (with admin rights and Excel closed) nothing happens.

In my new job IT staff are not very acquuainted with Eviews installation, so I would like to ask for advice so as to identify the source of the problem.

Thanks!

Fede

Excel version: 16.0.4549.1000 32bits

=======
PRODUCT
=======
Version: EViews 11 64-bit
Build date: Apr 23 2019
Serial Number: 10J00010

=========
LICENSING
=========
Lisource: C:\Program Files\EViews\lisource.txt
Concurrent 10J00010: svm0130:25750/EViews11

=====
PATHS
=====
Installation path: C:\Program Files\EViews
Default path: C:\USR\
INI path: Y:\BECFGUSR\EVW11
DB INI path: Y:\BECFGUSR\EVW11
Help path: C:\Program Files\EViews\Help Files

===========
ENVIRONMENT
===========
OS: Windows 10 x64
Cores in use: 8
Attachments
REGCOM.png
REGCOM.png (19.46 KiB) Viewed 6121 times

EViews Steve
EViews Developer
Posts: 654
Joined: Tue Sep 16, 2008 3:00 pm
Location: Irvine, CA

Re: REGCOMPONENTS issue

Postby EViews Steve » Mon Nov 30, 2020 4:48 pm

A few things:

First, you need to have the files on your system. Look for the "Excel2010AddIn" folder inside your EViews program directory. There should be some files in there named "EViews_Excel2010_40_AddIn.dll" and the like.
excel_add_ins_files.png
excel_add_ins_files.png (26.98 KiB) Viewed 6082 times

If you don't have files in this folder, then you didn't select the Excel Add In during EViews installation. Re-install and select the add in to get the files.

Second, our installer installs a Microsoft Visual Studio 2010 Tools for Office Runtime which is needed by our add-in to work properly on a machine. You can see the list of pre-requisites for the Excel 2010 add-in on this page and also download them separately and install them manually.

Finally, you'll want to make sure the add-in is properly registered by EViews to work with Excel. You do that via the REGCOM command you already tried and clicking the "Yes(All)" button to re-register everything. As a suggestion, make sure Excel isn't running when you do this.

Afterwards, run Excel and if you don't see the Add Ins ribbon menu, then go to Excel File menu/Options then select "Add-ins" in the left list box.
excel_add_ins_options.png
excel_add_ins_options.png (42.93 KiB) Viewed 6082 times

Select "COM Add-ins" in the Manage dropdown, then click Go. You should see the following dialog:
excel_add_ins_options_2.png
excel_add_ins_options_2.png (15.58 KiB) Viewed 6082 times

Make sure the checkbox next to "EViews Add-In for Excel 2010" is checked. Also, look at the Location label at the bottom to verify that it's pointing to a location that is valid on your machine. If this label is invalid, you'll have to run REGCOM again. Let me know if you have trouble with this.

Steve

jfgeli
Posts: 72
Joined: Fri Jan 30, 2009 6:29 pm

Re: REGCOMPONENTS issue

Postby jfgeli » Wed Dec 02, 2020 4:35 am

Thanks! I passed this info to my IT colleagues. I will come back soon with an update.
Cheers,
Fede


Return to “Installation and Registration”

Who is online

Users browsing this forum: No registered users and 2 guests