Partial Loads of Workfiles

For questions regarding the import, export and manipulation of data in EViews, including graphing and basic statistics.

Moderators: EViews Gareth, EViews Jason, EViews Steve, EViews Moderator

JeffvdN
Posts: 9
Joined: Thu Aug 02, 2018 12:18 pm

Partial Loads of Workfiles

Postby JeffvdN » Fri Apr 26, 2019 2:50 pm

All of a sudden, I am having trouble opening my workfiles. It opens them as untitled and I get this message,

"File contains an object that can not be loaded. It may have
been saved by another version of EViews. A partial load was
done in "WFUSE..."

I have never had this problem before.

The workfile I am using now is the result of some imports from Excel. Some of the series had all NAs so are showing up as alpha series but that has not been a problem before.

When I recreate the workfile from scratch is saves without incident. How can I find the problem object? Did the April 15 update change something that relates to the opening of workfiles?

I using Eviews 10+ Standard Edition - Apr 15 2019

In my prior post, I thought it was due to the daily tabs being named "D" that is not it. This workfile has the daily tab named D7. And I see from the other post's thread that "d" works.

Any ideas?

EViews Gareth
Fe ddaethom, fe welon, fe amcangyfrifon
Posts: 12317
Joined: Tue Sep 16, 2008 5:38 pm

Re: Partial Loads of Workfiles

Postby EViews Gareth » Fri Apr 26, 2019 2:55 pm

Generally happens when the workfile you're trying to open was created in a later version of EViews, or a beta copy.
Follow us on Twitter @IHSEViews

JeffvdN
Posts: 9
Joined: Thu Aug 02, 2018 12:18 pm

Re: Partial Loads of Workfiles

Postby JeffvdN » Sat Apr 27, 2019 8:21 am

Not in this case. In one of my workfies for example, I keep creating the workfile from scratch and it keeps happening. No warning when saving, but then won't reopen. In another big, old workfile, I keep going back to a backup copy from last week and that opens fine, but when I save it, and reopen it, it also encounters the problem.

Perhaps my Eviews is corrupted? Should I reinstall? Or perhaps your April 15 update did something? My backup file that works is from April 19, but I don't remember when I let Eviews do its update to the April 15 version. It may have been after that?

Perhaps unrelated, it seems like I have been having more and more trouble with workfiles getting corrupted over time. Some of these workfiles are very old and pretty large (roughly 300-400 meg). I am thinking I need to adopt a new approach where workfiles are temporary and all permanent storage is in databases.

EViews Steve
EViews Developer
Posts: 569
Joined: Tue Sep 16, 2008 3:00 pm
Location: Irvine, CA

Re: Partial Loads of Workfiles

Postby EViews Steve » Mon Apr 29, 2019 6:35 am

If you create a small workfile and save it, is it unreadable? For example, try this small program to create a basic workfile:

Code: Select all

wfcreate a 1991 2019
series x = rnd
series y = rnd

Is this small workfile also unreadable after a save?

Or maybe the problem is with a specific object type in your workfile?

Remember that EViews will normally save one backup of your original workfile on each save (it's the file with the same name, but with a .~F1 file extension) so if you want to revert back to the original, simply rename that extension back to .WF1.

Also, if you're using EViews 10 (or later), you can click the Snapshot button in your workfile toolbar to periodically take save points of your workfile. For more info on Snapshots, see our help page for saving a workfile.

Steve

JeffvdN
Posts: 9
Joined: Thu Aug 02, 2018 12:18 pm

Re: Partial Loads of Workfiles

Postby JeffvdN » Mon Apr 29, 2019 7:12 am

Your little test file works. It is looking like it may be something I have added or changed since the backup. It is not happening to all of my workfiles. I think it is just 3 but I am not sure what they have in common. We do a lot of imports of data from Excel from Bloomberg downloads. Maybe there is something funky in one of those files. Is there an easy to know where the bad object is? Or a way to compare 2 versions of a workfile to see what has been added or changed? I imagine I could write some code, unless you have some.

To avoid random crashing, I have broken my big programs that take over an hour to run into multiple chunks. Each has to save, close and reopen the workfiles. With this bug, I can't do that. I have been meaning to look into what is causing the random crashes but not today.

Over the weekend, I started rewriting the code to start with a fresh much smaller workfile each time. That probably is a good idea anyway. But it looks like that is going to take several days.

Any ideas how to find the bad object?

EViews Steve
EViews Developer
Posts: 569
Joined: Tue Sep 16, 2008 3:00 pm
Location: Irvine, CA

Re: Partial Loads of Workfiles

Postby EViews Steve » Mon Apr 29, 2019 7:18 am

So you're using EViews 10?

There isn't a good way to find a bad object. If you can send me the workfile, I can try and load it using a debugger to see which object is causing the problem. If you want to send me the workfile privately, send it to my email address: steve.yoo@ihsmarkit.com.

EViews does have a compare feature so you can see what changed in a workfile. To use this, load one of the workfiles, click the View button/Compare, then type in the name of a different workfile you'd like to compare it to. If it can load the other workfile, it will compare objects and show you any that have different data, etc. See our reference for WFCOMPARE for command details.


Return to “Data Manipulation”

Who is online

Users browsing this forum: No registered users and 3 guests