Different results for running state space models

For technical questions regarding estimation of single equations, systems, VARs, Factor analysis and State Space Models in EViews. General econometric questions and advice should go in the Econometric Discussions forum.

Moderators: EViews Gareth, EViews Moderator

adamsmith212
Posts: 2
Joined: Thu Jan 10, 2019 9:23 am

Different results for running state space models

Postby adamsmith212 » Thu Jan 10, 2019 2:02 pm

Hi,

I am running a state space model (time varying parameter) and trying to plot the smoothed states. I am able to do this. However, when I change the specification, estimate, and then change it back to the EXACT original specification - my estimates are completely different. A concrete example:

Here is what I do:

I load up a workfile with the following specification:

@ename e1
@ename e2
@ename e3

@evar var(e1) = exp(C(1))
@evar var(e2) = exp(C(2))
@evar var(e3) = exp(C(3))


@signal spread_1d = mp1*beta1 + path*beta2 + e1
@state beta1 = beta1(-1) + e2
@state beta2 = beta2(-1) + e3

I then edit the spec and run this:
@ename e1
@ename e2
@ename e3

@evar var(e1) = exp(C(1))
@evar var(e2) = exp(C(2))
@evar var(e3) = exp(C(3))


@signal spread_1d = mp1*beta1 + e1
@state beta1 = beta1(-1) + e2

I then edit the spec and run this:
@ename e1
@ename e2
@ename e3

@evar var(e1) = exp(C(1))
@evar var(e2) = exp(C(2))
@evar var(e3) = exp(C(3))


@signal spread_1d = path*beta1 + e1
@state beta1 = beta1(-1) + e2

and after running the original spec, I cannot get the original estimation results.

Do you have any insight or idea into this? In other words, when I change the specification and re-estimate, I cannot get back the original results. My smoothed estimates are just a flat horizontal line.

Thank you

startz
Non-normality and collinearity are NOT problems!
Posts: 3405
Joined: Wed Sep 17, 2008 2:25 pm

Re: Different results for running state space models

Postby startz » Thu Jan 10, 2019 3:55 pm

Starting values (in the C vector) matter.

adamsmith212
Posts: 2
Joined: Thu Jan 10, 2019 9:23 am

Re: Different results for running state space models

Postby adamsmith212 » Fri Jan 11, 2019 9:16 am

Thank you. How would you suggest that I estimate my code so that each time I do so, I get the same estimation values? In other words, get the same results each time I run the code.

EViews Gareth
Fe ddaethom, fe welon, fe amcangyfrifon
Posts: 11923
Joined: Tue Sep 16, 2008 5:38 pm

Re: Different results for running state space models

Postby EViews Gareth » Fri Jan 11, 2019 9:29 am

Follow us on Twitter @IHSEViews


Return to “Estimation”

Who is online

Users browsing this forum: No registered users and 7 guests