EViews 11 crashes when using fetch to get data from FRED

For notifying us of what you believe are bugs or errors in EViews.
Please ensure your copy of EViews is up-to-date before posting.

Moderators: EViews Gareth, EViews Moderator

MCD_nz
Posts: 2
Joined: Fri May 17, 2019 2:45 pm

EViews 11 crashes when using fetch to get data from FRED

Postby MCD_nz » Fri May 17, 2019 3:14 pm

Hi,
When using EViews11, 64bit in Win10, EViews crashes on the fetch(m) command in the following program:

'Load US unemployment rate
wfcreate(wf=gas) m 2006m12 2013m12
dbopen(type=fred, server=api.stlouisfed.org/fred)
fetch(m) unrate
close FRED

The program works fine in EView10

EViews Gareth
Fe ddaethom, fe welon, fe amcangyfrifon
Posts: 12266
Joined: Tue Sep 16, 2008 5:38 pm

Re: EViews 11 crashes when using fetch to get data from FRED

Postby EViews Gareth » Fri May 17, 2019 3:22 pm

Thanks. We'll fix.
Follow us on Twitter @IHSEViews

EViews Steve
EViews Developer
Posts: 563
Joined: Tue Sep 16, 2008 3:00 pm
Location: Irvine, CA

Re: EViews 11 crashes when using fetch to get data from FRED

Postby EViews Steve » Sat May 18, 2019 10:49 am

We'll take a closer look on Monday, but we did just release a patch that had a fix for refresh & fetch. You might try getting the patch to see if the crash has already been resolved.

EViews Steve
EViews Developer
Posts: 563
Joined: Tue Sep 16, 2008 3:00 pm
Location: Irvine, CA

Re: EViews 11 crashes when using fetch to get data from FRED

Postby EViews Steve » Mon May 20, 2019 7:00 am

Crash has been confirmed. We'll post a fix as soon as possible.

mtrebing
Posts: 4
Joined: Fri Jan 16, 2009 3:06 pm

Re: EViews 11 crashes when using fetch to get data from FRED

Postby mtrebing » Mon Jul 22, 2019 8:33 am

Was wondering if this was fixed. I am having a problem with Haver retrieves using EViews 11 on Win 10 as well.
Using July 12, 2019 build. Here is the error: "Database Error: FRED library error: 'Error HRESULT E_FAIL has
been returned from a call to a COM component.'" My registry setup is same as Eviews 10 and it is working fine.

EViews Jason
EViews Developer
Posts: 759
Joined: Tue Sep 16, 2008 3:50 pm

Re: EViews 11 crashes when using fetch to get data from FRED

Postby EViews Jason » Mon Jul 22, 2019 9:25 am

1)The previously reported bug has been fixed.

2)You said you were
having a problem with Haver retrieves using EViews 11 on Win 10 as well.
Using July 12, 2019 build. Here is the error: "Database Error: FRED library error: 'Error HRESULT E_FAIL has
been returned from a call to a COM component."
Just to clarify, were you getting a FRED error when fetching from Haver? Or were you getting a different error?

3)From EViews 11, try typing the regcom command into the EViews command window and then pressing the Yes(all) button.

This will reregister all the EViews 11 components. This however may break EViews 10 fetching functionality but should fix all FRED/EViews 11 issues.

mtrebing
Posts: 4
Joined: Fri Jan 16, 2009 3:06 pm

Re: EViews 11 crashes when using fetch to get data from FRED

Postby mtrebing » Mon Jul 22, 2019 9:36 am

Yes, the problem occurs when I do a Fetch FRED::variable command.
I ran the regcom, and reregistered. Still having the problem, however. I did get an error: failed to register com automation and OLE. Possibly a security setting here?

This is a new machine so there are no EViews 10 leftovers. But I am considering installing an EViews 10 license on same machine to get around this problem. Sounds like that might create its own problems.

smr01
Posts: 9
Joined: Mon Oct 27, 2008 2:24 pm

Re: EViews 11 crashes when using fetch to get data from FRED

Postby smr01 » Mon Jul 22, 2019 2:11 pm

I am having a similar issue with a work file that has Fred Links. The error message is below and the variables change from try to try.

Unable to refresh series from database link: fred::dexcaus
fred::lns14000024 fred::wgs10yr fred::wslb20.

I noticed that the refresh hangs and a "Not Responding: message flashes on the title bar. It was working before the last patch.

I am using EV10 July 19 Version and I did do a regcom.

EViews Jason
EViews Developer
Posts: 759
Joined: Tue Sep 16, 2008 3:50 pm

Re: EViews 11 crashes when using fetch to get data from FRED

Postby EViews Jason » Mon Jul 22, 2019 2:52 pm

mtrebing,

Can you send me an email to Jason@eviews.com and refer to this thread? I'd like to have you run some tests.

smr01,

The FRED web servers appear to be a bit flakey. The responses from their servers are inconsistent. For the same series, we would sometimes get an 'unexpected content server' error (after a long delay) but if we immediately tried fetching again, the series would fetch fine.


Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 3 guests