Page 1 of 1

Bug using Eviews 11 and the excel add-in

Posted: Thu Apr 25, 2019 7:58 am
by Frdmn
Hello, When I'm using "get data" command in the excel addin I get the following error:

image (1).png
image (1).png (11.12 KiB) Viewed 1909 times


Do you know why? it worked with Eviews 10

Re: Bug using Eviews 11 and the excel add-in

Posted: Thu Apr 25, 2019 8:29 am
by EViews Steve
Can you provide more details? Specifically, I need to know the exact steps to recreate this issue as it seems to work fine on my machine. Was this during an attempt to import data from a new source or were you trying to refresh an existing connection?

Also, please provide the following environment details:
1. Windows version?
2. Excel version? Is this 32-bit or 64-bit Excel? A screenshot of the File/Account screen would suffice here.
3. EViews 11 build date? Is this 32-bit or 64-bit EViews? A screenshot of the Help menu/About EViews dialog would suffice here.
4. Have you ever had an older version of EViews on the same machine? If so, is it still there or has it been removed? Was the older version 32-bit or 64-bit?
5. Please run the command: SUPPORTINFO in the EViews command window and provide the text results here.

Thanks,

Steve

Re: Bug using Eviews 11 and the excel add-in

Posted: Thu May 23, 2019 7:37 pm
by manthonisz
Dear Steve,

I updated to Eviews 11 this week and just tried to use the Excel add-in. However, I encountered an error message (see attached doc) when trying to do so.

It looks like there was some issue with the deployment of the add-in and (perhaps) Eviews 11 is trying to access the Eviews 10 add-in to no avail.

Would you have any ideas on what I may do to correct this?

Thanks so much for any help you can give.

Regards,

Michael

Re: Bug using Eviews 11 and the excel add-in

Posted: Fri May 24, 2019 9:45 am
by EViews Steve
That error can happen if you uninstall EViews 10 and EViews 11 add-in didn't get registered properly.

To resolve this, shutdown Excel, then run EViews 11 and type in REGCOM into the command window and hit Enter. Click Yes(All) to re-register everything. Wait for the success message.

Now restart Excel. After it starts up, go to File/Options/Add Ins. Select "COM Add Ins" in the Manage dropdown and click Go. Make sure the EViews add-in for Excel 2010 is pointing at your EViews 11 folder. If you see others still pointing to EViews 10, uncheck the checkbox for those. Click OK to save changes.

You might have to restart Excel after these changes, but you should now have access to the EViews 11 Excel add-in. Note, we will update the Excel add-in for EViews 11 sometime next week with a few bug fixes and an updated graphic (the current one still uses the EViews 10 graphic for the Get Data button).

Steve

Re: Bug using Eviews 11 and the excel add-in

Posted: Sun May 26, 2019 4:37 pm
by manthonisz
Hi Steve,

That worked perfectly. Thanks very much for the quick and helpful response!

Regards,

Michael

Re: Bug using Eviews 11 and the excel add-in

Posted: Mon May 27, 2019 2:37 am
by jfgeli
Hi Steve,

I experience the same issue. I have upgraded to Eviews 11 from Eviews 10 (both 64 bits I believe). The result is the same whether I create a new connection or try to update an existing one.

I followed the steps of re-registering Eviews and making sure the add-in points to Eviews11 folder.

Is there anything else I could do?

Cheers,

Fede

supportinfo

=======
PRODUCT
=======
Version: EViews 11 64-bit
Build date: May 21 2019
Serial Number: 11C08442

=========
LICENSING
=========
Standalone 11C08442: C:\ProgramData\IHS EViews\EViews\11.00.000\license.txt

=====
PATHS
=====
Installation path: C:\Program Files\EViews 11
Default path: C:\Users\jfgeli\Documents
INI path: C:\Users\jfgeli\AppData\Roaming\IHS EViews\EViews
DB INI path: C:\Users\jfgeli\AppData\Roaming\IHS EViews\EViews
Help path: C:\Program Files\EViews 11\Help Files

===========
ENVIRONMENT
===========
OS: Windows 10 x64
Cores in use: 4

Re: Bug using Eviews 11 and the excel add-in

Posted: Mon May 27, 2019 3:02 am
by jfgeli
In addition, a colleague of mine who did the same upgrade does not have such a problem. The only difference in our specifications is the Excel version. He has a 32 bits version and I have a 64 bits version (version 1904).

Re: Bug using Eviews 11 and the excel add-in

Posted: Tue May 28, 2019 6:49 am
by EViews Steve
jfgeli:

We'll be releasing a few small bug fixes to the Excel 2010 add-in sometime this week. However, I don't think these fixes will help your particular case.

When we install EViews onto a machine, we try to make our various components (such as the OLEDB Provider dll which is used by the Excel add-in) available to both 32-bit and 64-bit processes. But there is a performance hit when you have a cross-bit use like that (such as when 64-bit Excel uses 32-bit EViews). So we suggest you install a matching bit-version of EViews to talk to Excel with the best performance. This means if you have 64-bit Excel installed, you should also have 64-bit EViews installed as well. With our licensing, you can have both 32-bit and 64-bit EViews using the same license on the same machine.

Also, installing 64-bit EViews can also help resolve any invalid path in your windows registry that is pointing to, perhaps, an older 64-bit installation path that no longer exists.

If you'd like to resolve this issue without installing 64-bit EViews, do the following:

1. Open a DOS prompt (command.exe) with local admin rights.
2. CD to your EViews 11 program directory (e.g. CD "C:\Program Files (x86)\EViews 11")
3. Type in and run the following command:

Code: Select all

regsvr32 EViewsOleDbProvider.dll

4. Wait for success message.
5. If you have an "x64" subdirectory, switch to that folder and re-run the same command as #3 above.
6. If you have an "x86" subdirectory, switch to that folder and re-run the same command as #3 above.
7. Restart Excel and try using the add-in again.

This process basically forces a registration of our EViews OleDb Provider in both 32-bit and 64-bit forms.

Ste

Re: Bug using Eviews 11 and the excel add-in

Posted: Tue May 28, 2019 8:02 am
by jfgeli
Hi Steve,

I have an Excel 64 bit version running in my machine. The Add in gave problems ith Eviews 64 bits. I have tried in two different computers (both running Excel 64 bits) with the same results. My Excel version is 16.0.11601.20130 64 bits

However, Eviews 64 bits works well in another computer with Excel 32 bits (my colleague┬┤s computer).

Besides this (small) difference, in the 3 computers we have the same settings (same operating system, network policy configuration, etc).

The way I have installed Eviews 11 was the following (I have admin privileges):

1)With Excel closed, I have uninstalled Eviews 10 64 bits
2)Opened Excel 64 bits and make sure it was not pointing to the COM-Add in from Eviews 10.
3)Closed Excel 64 bits
4)Deleted C:\Program Files\EViews 10
5)Cleaned Windows Registry. I manually searched the word Eviews and deleted all registry entries.
5)Run CC Cleaner to check the consistency of Windows Registry
6)Installed Eviews 11 64 bits
7)Opened Eviews 11 64 bits and run regcom
8)Opened Excel 64 bits

Is there anything I am missing? If possible, I would rather use Eviews and Excel both 64 bits. I attach a screenshot.

Cheers,

Federico

Re: Bug using Eviews 11 and the excel add-in

Posted: Tue May 28, 2019 8:04 am
by EViews Steve
What is your EViews 11 build date? Go to our Help menu/About EViews to see this value.

Re: Bug using Eviews 11 and the excel add-in

Posted: Tue May 28, 2019 8:58 am
by jfgeli
Below you can see the output of supportinfo command:

=======
PRODUCT
=======
Version: EViews 11 64-bit
Build date: May 21 2019
Serial Number: 11C08442

=========
LICENSING
=========
Standalone 11C08442: C:\ProgramData\IHS EViews\EViews\11.00.000\license.txt

=====
PATHS
=====
Installation path: C:\Program Files\EViews 11
Default path: C:\Users\jfgeli\Documents
INI path: C:\Users\jfgeli\AppData\Roaming\IHS EViews\EViews
DB INI path: C:\Users\jfgeli\AppData\Roaming\IHS EViews\EViews
Help path: C:\Program Files\EViews 11\Help Files

===========
ENVIRONMENT
===========
OS: Windows 10 x64
Cores in use: 4

Re: Bug using Eviews 11 and the excel add-in

Posted: Tue May 28, 2019 10:07 am
by EViews Steve
Ah, sorry for the duplicate request.

I will attempt to reproduce your issue with Excel 64-bit. Once I have more information, I'll let you know.

In the meantime, did you manually re-register the EViewsOleDbProvider.dlls like I mentioned in my previous post?

Re: Bug using Eviews 11 and the excel add-in

Posted: Tue May 28, 2019 2:42 pm
by EViews Steve
I was able to reproduce the problem with Excel 64-bit, and I also confirmed that the latest updates to the Excel 2010 add-in for EViews 11 fixes the issue.

We'll release this patch as soon as possible.

Steve

Re: Bug using Eviews 11 and the excel add-in

Posted: Wed May 29, 2019 7:44 am
by jfgeli
Excellent!
A million thanks ;)