Excel link

For notifying us of what you believe are bugs or errors in EViews.
Please ensure your copy of EViews is up-to-date before posting.

Moderators: EViews Gareth, EViews Moderator

white01
Posts: 4
Joined: Wed Mar 10, 2010 2:42 pm

Excel link

Postby white01 » Wed Mar 10, 2010 3:03 pm

I tried to import data from an Eviews file (wf1) from Excel 2007, everything is OK, I choosed the variable to import and I selected the cell to input the data, then an error message appeared:

"Initialization of the data source failed.
Check the database server or contact your database administrator.
Make sure the external database is available, and then try the operation
again. If you see this message again, create a new data source
to connect to the database. "

any idea?? (I'm using windows 7 and EViews 7 build Dec 2)

EViews Gareth
Fe ddaethom, fe welon, fe amcangyfrifon
Posts: 12371
Joined: Tue Sep 16, 2008 5:38 pm

Re: Excel link

Postby EViews Gareth » Wed Mar 10, 2010 3:14 pm

That's a really old version of EViews 7. Could you update and see if the problem still persists. If it does, could you post the Excel file, along with instructions on which cell/sheet you were trying to import etc...?
Follow us on Twitter @IHSEViews

white01
Posts: 4
Joined: Wed Mar 10, 2010 2:42 pm

Re: Excel link

Postby white01 » Thu Mar 11, 2010 2:04 am

Well I updated to build Mar-8-10, and I still have the same problem.
Note: I open a new Excel file, I choose "Get Data" from the "EViews" add-in, I choose the attached "index.wf1" file from "Select an EViews file to open" dialog box, a "Get EViews data" box appears, so I choose one variable or more and pressed "Add" or "Add all" (I tried all combinations); after pressing "Import" I choose an insert point "$A$1", just after pressing "Ok" the error message appears and the "Get EViews data" box reappears.
Attachments
index.wf1
(353.69 KiB) Downloaded 183 times

EViews Steve
EViews Developer
Posts: 581
Joined: Tue Sep 16, 2008 3:00 pm
Location: Irvine, CA

Re: Excel link

Postby EViews Steve » Thu Mar 11, 2010 8:47 am

Hello:

I just tested our Add In using your workfile and it seems to work fine for me. I would suggest doing the following:

Run EViews7 and type in:

Code: Select all

REGCOMPONENTS

in the command window. This will bring up a popup that will give you the opportunity to re-register all COM and AddIn components associated with EViews7. Click "Yes" and allow any security popups that come up to proceed (this requires Admin privileges).

Once done, restart Excel and try the Add In again.

If you continue to get the error, most likely there's a problem with the installation of EViews7 on your machine. Let me know what you find...

Steve

EViews Steve
EViews Developer
Posts: 581
Joined: Tue Sep 16, 2008 3:00 pm
Location: Irvine, CA

Re: Excel link

Postby EViews Steve » Thu Mar 11, 2010 8:50 am

By the way, did you ever have EViews 7 Beta installed?

white01
Posts: 4
Joined: Wed Mar 10, 2010 2:42 pm

Re: Excel link

Postby white01 » Thu Mar 11, 2010 11:25 am

Yes, I've had EViews Beta installed, then I just deleted its folder before installing EViews.

EViews Steve
EViews Developer
Posts: 581
Joined: Tue Sep 16, 2008 3:00 pm
Location: Irvine, CA

Re: Excel link

Postby EViews Steve » Thu Mar 11, 2010 11:59 am

Did REGCOMPONENTS help?

white01
Posts: 4
Joined: Wed Mar 10, 2010 2:42 pm

Re: Excel link

Postby white01 » Thu Mar 11, 2010 12:19 pm

Problem solved. Thanks.


Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 3 guests