EViews10+: LogSave

For notifying us of what you believe are bugs or errors in EViews.
Please ensure your copy of EViews is up-to-date before posting.

Moderators: EViews Gareth, EViews Moderator

nilslh
Posts: 8
Joined: Fri Sep 08, 2017 2:38 am

EViews10+: LogSave

Postby nilslh » Wed May 16, 2018 6:11 am

Hi,

I have encountered a problem in EViews 10+ (build Apr 24 2018). When just typing

Code: Select all

LogSave "[path]"


I get the error message Log name was not found in "LOGSAVE "[path]"". Notice that there is a space after Log name in the error message (does not appear in this post). I do not get any error message using EViews 9.5. Note also that I have not used any command before LogSave, e.g. LogMode or similar. For instance the following works properly:

Code: Select all

LogMode -all s
Statusline "Test 1"
LogSave "[path]"


Regards,
Nils

nilslh
Posts: 8
Joined: Fri Sep 08, 2017 2:38 am

Re: EViews10+: LogSave

Postby nilslh » Wed May 16, 2018 6:54 am

Furthermore, specifying LogMode does not work properly. Both error (e), logmsg (l) and -program (-p) causes EViews to crash in the following context:

Code: Select all

LogMode l
LogSave "[path]"


However, p works fine for example.

Best,
Nils

EViews Katerina
Posts: 10
Joined: Thu Jun 25, 2015 9:54 am

Re: EViews10+: LogSave

Postby EViews Katerina » Thu May 17, 2018 1:15 pm

Next patch of EViews10+ will include fixes for the LogSave command issues.

Until next patch, you can still use the LogSave command in your program but you need to move it after a LogMsg command:
LogMode l
LogMsg mymsg
LogSave "[path]"


Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 2 guests