Cointegration Test gives wrong P-Value

For notifying us of what you believe are bugs or errors in EViews.
Please ensure your copy of EViews is up-to-date before posting.

Moderators: EViews Gareth, EViews Moderator

grabodan
Posts: 7
Joined: Thu Jun 11, 2015 6:36 am

Cointegration Test gives wrong P-Value

Postby grabodan » Tue May 15, 2018 5:53 am

Dear EViews-Team
When I perform a Johansen Cointegration Test for a VAR and the Trace od ME Test Statistic are much larger than the critical value, the p-value should be close to zero. Instead, I shows the Prob: 1.0000.
The programm code I used, just as an example, was:

Code: Select all

wfcreate(wf=Koint) u 10000
smpl @all
series x=0
series y=0
series z=0
series trend = 0
smpl @first+1 @last
series u=@nrnd
series v=@nrnd
series w=@nrnd
trend = 1+trend(-1)+@nrnd
x= trend + u
y= y(-1) + 0.5*(x(-1) - y(-1))  + v
z= 10 + z(-1) + w
varest 1 1 x y z


I am using EViews 10, but I think I have encountered the same problem already years ago with Version 8 or so.

Edit: The issue disappears if, e.g., I reduce the number of obs to 1000 such that the p-value is 0.0001 or such. Thus, I only appears for p-values extreme close to zero, displaying 1 instead.

Best regards,
Daniel
Attachments
koint.wf1
(665.94 KiB) Downloaded 12 times

EViews Glenn
EViews Developer
Posts: 2590
Joined: Wed Oct 15, 2008 9:17 am

Re: Cointegration Test gives wrong P-Value

Postby EViews Glenn » Tue May 15, 2018 9:37 am

Thanks. We will take a look.

EViews Glenn
EViews Developer
Posts: 2590
Joined: Wed Oct 15, 2008 9:17 am

Re: Cointegration Test gives wrong P-Value

Postby EViews Glenn » Fri May 25, 2018 4:47 pm

We've identified the issue.

In the MacKinnon algorithm for the response surface, we have found that there are potential issues with the polynomial approximation to the response surface for extreme values. In this case, the statistic value is so out of bounds that the existing algorithm approximation is quite poor. We have implemented a fix for the tail conditions which provides additional robustness to these large values and are in the process of testing the changes. A fix will appear soon (most likely in the next patch for EViews 10).

Thank you for your patience.

grabodan
Posts: 7
Joined: Thu Jun 11, 2015 6:36 am

Re: Cointegration Test gives wrong P-Value

Postby grabodan » Mon Jun 04, 2018 6:31 am

Thanks for the response,
Daniel


Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 2 guests