EViews 10+: Crash when calling subroutine

For notifying us of what you believe are bugs or errors in EViews.
Please ensure your copy of EViews is up-to-date before posting.

Moderators: EViews Gareth, EViews Moderator

nilslh
Posts: 8
Joined: Fri Sep 08, 2017 2:38 am

EViews 10+: Crash when calling subroutine

Postby nilslh » Wed May 09, 2018 2:03 am

I realised that I needed to create a new topic in order for the post to be marked as unread.

nilslh wrote:Hi,

I have a related problem using EViews 10+. When calling a subroutine within a subroutine, EViews occasionally crashes. The problem seems to be related to the number of maximum allowable errors. When setting the number manually to 100 (in EViews, via General Options) and in the subroutine to 1 (SetMaxErrs 1) I get a message that the number of maximum allowable errors has been exceeded. Then I remove the code snippet (SetMaxErrs 1) and run the program again and everything works well. Then I close EViews and run the program again, with the same options and without changing anything, and EViews crashes.

I am using Windows 10 and from the Event Viewer I got the information that the error arose from module "evCommon.dll". Not sure if that information is helpful.

Regards,
Nils


In another program (that includes subroutines) I have experienced random crashes that seems to be unrelated to the actual code, as EViews on one occasion crashes at a certain position in the program, but the next time does not but is able to continue past that position. However, then it crashes at the last line which is a simple "Statusline". Sorry for the bad description, but it seems to happen unsystematically.

Regards,
Nils

EViews Gareth
Fe ddaethom, fe welon, fe amcangyfrifon
Posts: 11733
Joined: Tue Sep 16, 2008 5:38 pm

Re: EViews 10+: Crash when calling subroutine

Postby EViews Gareth » Wed May 09, 2018 7:33 am

Would it be possible to provide an example?
Follow us on Twitter @IHSEViews

EViews Steve
EViews Developer
Posts: 504
Joined: Tue Sep 16, 2008 3:00 pm
Location: Irvine, CA

Re: EViews 10+: Crash when calling subroutine

Postby EViews Steve » Wed May 09, 2018 7:50 am

It would also help to know the build date of your copy of EViews. You may be experiencing a bug that has already been fixed with EViews 10.

To get your build date, open EViews 10 and go to the Help menu/About EViews.

nilslh
Posts: 8
Joined: Fri Sep 08, 2017 2:38 am

Re: EViews 10+: Crash when calling subroutine

Postby nilslh » Tue May 15, 2018 5:51 am

I discovered that the crashes are caused by inserting a double \r into a string (inserting a line break twice). It can be solved by using the ASCII command @Chr(13) instead. However, the crashes happen irrregularly and sometimes it is possible to run the code with \r without EViews crashing... For example, if you run the code below 20 times, EViews will (probably) crash a couple of times. When replacing \r with @Chr(13) it will function properly.

This example causes EViews to crash at least 2/20 times...

Code: Select all

WfCreate(Wf = Temp) Q 2010 2018

Vector(3) AL_DistVec
AL_DistVec.Fill 0.1, 0.3, 0.4

Freeze(AL_Hist) AL_DistVec.DistPlot(leg=short)

%AL_DistInfo = "First line" + "\r" + "\rSecond line"

AL_Hist.AddText(0,3.75,Framecolor(black)) %AL_DistInfo


... while this example causes EViews to crash 0/20 times.

Code: Select all

WfCreate(Wf = Temp) Q 2010 2018

Vector(3) AL_DistVec
AL_DistVec.Fill 0.1, 0.3, 0.4

Freeze(AL_Hist) AL_DistVec.DistPlot(leg=short)

%AL_DistInfo = "First line" + "\r" + @Chr(13) + "Second line"

AL_Hist.AddText(0,3.75,Framecolor(black)) %AL_DistInfo


I am using EViews 10+, Enterprise edition - Apr 24 2018 build.

Regards,
Nils

EViews Steve
EViews Developer
Posts: 504
Joined: Tue Sep 16, 2008 3:00 pm
Location: Irvine, CA

Re: EViews 10+: Crash when calling subroutine

Postby EViews Steve » Tue May 15, 2018 7:09 am

Great catch. The fix will be in the next patch.

Steve


Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 2 guests