Display Names Dropping Off...

For notifying us of what you believe are bugs or errors in EViews.
Please ensure your copy of EViews is up-to-date before posting.

Moderators: EViews Gareth, EViews Moderator

kcaron
Posts: 40
Joined: Wed Mar 04, 2015 11:46 am

Display Names Dropping Off...

Postby kcaron » Fri Dec 23, 2016 1:44 pm

I keep having an issue wherein I go through each series and type in Display Names (Series > View > Labels)...

They seem to be retained for a little while but whenever I close and restart EViews they disappear.

I'm sure that I am saving the file each time... I just can't figure out why this keeps happening. I'm spending lots of time just re-entering Display Names...

I'm using EViews 9.5 Enterprise Edition, November 14, 2016 Build...

Thanks for any help!

Kevin

EViews Gareth
Fe ddaethom, fe welon, fe amcangyfrifon
Posts: 11299
Joined: Tue Sep 16, 2008 5:38 pm

Re: Display Names Dropping Off...

Postby EViews Gareth » Fri Dec 23, 2016 2:16 pm

Could you provide an example workfile?
Follow us on Twitter @IHSEViews

kcaron
Posts: 40
Joined: Wed Mar 04, 2015 11:46 am

Re: Display Names Dropping Off...

Postby kcaron » Fri Dec 23, 2016 2:48 pm

Here you go...
Attachments
2017 outlook.wf1
(723.02 KiB) Downloaded 23 times

kcaron
Posts: 40
Joined: Wed Mar 04, 2015 11:46 am

Re: Display Names Dropping Off...

Postby kcaron » Sat Jan 07, 2017 10:43 am

Still having issues with this even after running the December patch.

As a workaround, is there a program that could be written to write the Display Names? If there were, it would save a lot of time from continually having to re-enter each display name by hand...

Thanks!

kcaron
Posts: 40
Joined: Wed Mar 04, 2015 11:46 am

Re: Display Names Dropping Off...

Postby kcaron » Sat Jan 07, 2017 12:50 pm

Nevermind... I figured that one out...

series.displayname whatever

This works great...

But now the percentage formatting on my data table keeps reverting back to the table default... Any idea how to use a program to set the format of the row on a data table?

Thanks!

EViews Steve
EViews Developer
Posts: 434
Joined: Tue Sep 16, 2008 3:00 pm
Location: Irvine, CA

Re: Display Names Dropping Off...

Postby EViews Steve » Mon Jan 09, 2017 8:32 am

When you open the workfile after saving the display names, are you, by any chance, clicking Yes on the dialog that asks to refresh all links? Do the display names stick around if you say No?

I'm not able to recreate your displayname issue so if you're still having that problem, please describe the details on how you're able to recreate this problem. I'll need to know which page and series object you're changing the displayname and how you're changing it, also what you're clicking on after you open the workfile and the refresh dialog comes up.

Steve


Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 2 guests