Wildcard character when querying IHS Magellan

For notifying us of what you believe are bugs or errors in EViews.
Please ensure your copy of EViews is up-to-date before posting.

Moderators: EViews Gareth, EViews Moderator

jthodge
Posts: 77
Joined: Tue Oct 21, 2008 5:52 am

Wildcard character when querying IHS Magellan

Postby jthodge » Fri Apr 22, 2016 6:48 am

The "@" symbol in the name of many series in the IHS Magellan databanks appears to be causing an issue when querying and/or fetching from the database using a wildcard character.

For example, neither of the fetch commands below will retrieve anything from the RFOR databank on IHS Magellan

Code: Select all

wfcreate(wf=regionalmacro) q 1960:01  2020:04
dbopen rfor
fetch NR@*.Q
fetch NR@??.Q

However, the following fetch command that replaces "@" with the ? wildcard (and ?? for state abbreviations) will retrieve the total population forecast series for all of the states (e.g. nr@ak.q, which Eviews automatically renames as nr_ak):

Code: Select all

fetch NR???.Q

This behavior seems to have popped up when Eviews 9.5 was released or shortly before. Is this a bug or an intentional change?

EViews Jason
EViews Developer
Posts: 764
Joined: Tue Sep 16, 2008 3:50 pm

Re: Wildcard character when querying IHS Magellan

Postby EViews Jason » Wed Apr 27, 2016 7:34 am

A fix is in progress. It should not require an EViews patch since it is being fixed on the Magellan side. We will post when we believe it is fixed.

EViews Jason
EViews Developer
Posts: 764
Joined: Tue Sep 16, 2008 3:50 pm

Re: Wildcard character when querying IHS Magellan

Postby EViews Jason » Thu Jun 09, 2016 10:24 am

The Magellan folks have reported that this has been fixed.


Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 14 guests