Page 1 of 1

Error when querying/fetching IHS Magellan database

Posted: Tue Apr 05, 2016 2:16 pm
by troy_walters
I am attempting to query an IHS Magellan database. I get the following error message when doing so:

Code: Select all

Database Error: Magellan library error: '[System.
ArgumentNullException: Value cannot be null.
Parameter name: String]
   at System.Number.StringToNumber(String str,
 NumberStyles options, NumberBuffer&& number,
 NumberFormatInfo info, Boolean parseDecimal)
   at System.Numb.


This happens only sometimes, not everytime. It occurs when querying/fetching and the issue is not limited to any one particular databank. At other times I get an error message stating the the object does not exist. But when I access the Magellan api via another method (e.g. AREMOS), the object is there. Help?

Re: Error when querying/fetching IHS Magellan database

Posted: Tue Apr 05, 2016 3:23 pm
by EViews Jason
You said it was inconsistent from one databank to another, but how a particular series? For the same series, are you getting consistent behavior?

What is an example series that produces the reported error?

What is an example series that 'does not exist'?

Is this a recent phenomena or has this always been a problem?

Re: Error when querying/fetching IHS Magellan database

Posted: Wed Apr 06, 2016 7:18 am
by troy_walters
It also also inconsistent across series.

I am trying to reproduce the error. But today I am getting a different error at the same spot:

Code: Select all

Database Error: Magellan library error: 'Index was out of
 range. Must be non-negative and less than the size of the
 collection.
Parameter name: index' in "COPY REGCON::POIIA
 "STATERE0216"::FHFAPOIIA".


The above series POIIA in the Magellan REGCON "bank" is an example. I should point out that in that example I am using the copy command, but this problem happens during fetch and queries as well.

These errors (and similar) are relatively new. I have only encountered them over the past two weeks. Prior to that I had never seen them.

Re: Error when querying/fetching IHS Magellan database

Posted: Wed Apr 06, 2016 11:33 am
by EViews Jason
Can you post the full 'copy' command you are using?

It is strange that Magellan is returning

Code: Select all

Parameter name: index' in "COPY REGCON::POIIA
 "STATERE0216"::FHFAPOIIA".


The 'copy' portion of the command should never get sent to Magellan.

What happens when you run the below code?

Code: Select all

create u 100
fetch poiia.q

Re: Error when querying/fetching IHS Magellan database

Posted: Wed Apr 06, 2016 12:37 pm
by troy_walters
This is the copy command I am using:

Code: Select all

for %reg {%streg}
   copy regcon::poi{%reg} %new_st::fhfapoi{%reg}
next



When I run your code:

Code: Select all

create u 100
fetch poiia.q


it works ok right now, but again, I am only getting these errors sporadically, which makes it challenging to reproduce at any given moment.

Sometimes my above code runs fine. Most recently it failed again at the same place, this time with a third different error msg:

Code: Select all

Database Error: Magellan library error: 'Object reference not set to an instance of an object.' in "COPY REGCON::POICMAC "STATERE0216"::FHFAPOICMAC".

Re: Error when querying/fetching IHS Magellan database

Posted: Wed Apr 06, 2016 1:46 pm
by EViews Jason
In your example, what is statere0216? Is it an EViews database?

Also try changing your command to

Code: Select all

 copy regcon::poi{%reg} {%new_st}::fhfapoi{%reg}


Does that help?

Re: Error when querying/fetching IHS Magellan database

Posted: Thu Apr 07, 2016 12:15 pm
by troy_walters
It's an EViews workfile. No it's still throwing the error on that line after I make your suggested change. Except that today, rather than throwing one of the three error messages I described earlier, its just saying that the series REGCON::POIAL was not found. But I know it's there. I'm not sure at this point. Given the sporadic behavior of this error its really hard to troubleshoot.

Re: Error when querying/fetching IHS Magellan database

Posted: Wed Apr 27, 2016 7:42 am
by EViews Jason
The Magellan folks think they may have found the problem. A fix will hopefully be in place soon. We will post back with any updates.

Re: Error when querying/fetching IHS Magellan database

Posted: Fri Apr 29, 2016 10:54 am
by troy_walters
Great thank you!

Re: Error when querying/fetching IHS Magellan database

Posted: Fri May 13, 2016 10:54 am
by EViews Jason
We have been informed the problem have been fixed. Please report any issues.

Re: Error when querying/fetching IHS Magellan database

Posted: Mon Jun 06, 2016 11:57 am
by troy_walters
Thanks Jason. So far so good. I'll let you know if anything else comes up.