Problem when page extended in subroutine with local smpl

For notifying us of what you believe are bugs or errors in EViews.
Please ensure your copy of EViews is up-to-date before posting.

Moderators: EViews Gareth, EViews Moderator

etienne
Posts: 19
Joined: Wed Jun 12, 2013 10:32 am

Problem when page extended in subroutine with local smpl

Postby etienne » Mon Feb 22, 2016 1:38 pm

Hi,

EViews doesn't give the expected result when a pagestruct command to extend a workfile page is executed within a subroutine with local smpl.

Try this:

Code: Select all

wfcreate a 2010 2015
series x = @runif(0, 1)

subroutine sub
  local smpl

  pagestruct(end=2020)
endsub

call sub


After running this code, the total number of observations displayed in the workfile page is wrong and, when the series is open, values displayed are incorrect : where extended years should appear, the first year of the original series and the corresponding value are repeated.

However, the values obtained by code, such as x[7], seems to be correct.

This bug, which appears both in EViews 8.1 and in EViews 9, is easy to avoid, though, by running the pagestruct command before the local smpl instruction.

Best regards,

Étienne

EViews Gareth
Fe ddaethom, fe welon, fe amcangyfrifon
Posts: 12242
Joined: Tue Sep 16, 2008 5:38 pm

Re: Problem when page extended in subroutine with local smpl

Postby EViews Gareth » Mon Feb 22, 2016 1:53 pm

Ok, we'll fix (which will probably be just disabling pagestruct or other workfile type commands under a local smpl).
Follow us on Twitter @IHSEViews


Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 4 guests