IHS Global Insight Database Connection

For making suggestions and/or requests for new features you'd like added to EViews.

Moderators: EViews Gareth, EViews Moderator

mmiller2
Posts: 7
Joined: Tue Aug 23, 2016 9:56 am

IHS Global Insight Database Connection

Postby mmiller2 » Tue Jul 10, 2018 6:57 am

Would it be possible to add the User-Agent property to the HTTP request header when making a connection to IHS Global Insight Databases? My outbound HTTP traffic is filtered and requests that do not include a pre-approved User-Agent are rejected by the gateway with a 403: NotSupportedBrowser error.

Currently, the HTTP request for connection to an IHS Global Insight Database looks like this:

Code: Select all

CONNECT magapi.ihsglobalinsight.com:443 HTTP/1.1
Host: magapi.ihsglobalinsight.com
Proxy-Connection: Keep-Alive


Notice the User-Agent is not part of that header as it normally is when performing other remote operations in EViews like checking for updates:

Code: Select all

GET http://www.eviews.com/EViewsMsgs/msgs.xml HTTP/1.1
Cache-Control: no-cache
Proxy-Connection: Keep-Alive
Pragma: no-cache
Accept: text/*
User-Agent: EViews64/10.00
Host: www.eviews.com
Attachments
EViewsError.png
EViewsError.png (16.85 KiB) Viewed 442 times

EViews Steve
EViews Developer
Posts: 530
Joined: Tue Sep 16, 2008 3:00 pm
Location: Irvine, CA

Re: IHS Global Insight Database Connection

Postby EViews Steve » Tue Jul 10, 2018 7:40 am

I've submitted this question to the DataInsight team that developed the EDX control that EViews uses. At this point, there's isn't an easy way to adjust the UserAgent field on their connections, but if they come up with something, I'll let you know.

Steve

EViews Steve
EViews Developer
Posts: 530
Joined: Tue Sep 16, 2008 3:00 pm
Location: Irvine, CA

Re: IHS Global Insight Database Connection

Postby EViews Steve » Tue Jul 10, 2018 8:03 am

I took a quick look at some of the network settings for DataInsight and it does have support for specifying a proxy server, but there isn't any setting for UserAgent.

If you setup a proxy server on your local machine, then point DataInsight to it, that might allow you to get around the UserAgent issue as the proxy server may provide override the request with it's own header values. To setup the proxy server, you can follow these instructions in Appendix A in this PDF document:
http://cdn1.eviews.com/IHSDataInsightBrowser.pdf

Steve


Return to “Suggestions and Requests”

Who is online

Users browsing this forum: No registered users and 7 guests