Duplicate year on graph axis

For requesting general information about EViews, sharing your own tips and tricks, and information on EViews training or guides.

Moderators: EViews Gareth, EViews Moderator

fieldstream
Posts: 3
Joined: Fri Sep 30, 2016 7:59 am

Duplicate year on graph axis

Postby fieldstream » Fri Sep 30, 2016 9:51 am

I created a graph of my data in EViews. On the x axis the graph repeated the first year (only). I set the graph to "label start of period" and that suppressed the duplicate first year.

However, when I copy the graph and paste to a Word file, the duplicate first year reappears. Clicking through its link back to Eviews and changing it does not remedy the problem. (attached).
graph w duplicate first year.doc


When I save the graph as an image (.jpg), there is no problem (attached).
ratiobondsgraph.jpg


Is there a way to get this to appear properly in Word directly from Eviews as OLE or emf, like the Eviews instructions say?

Thank you for your assistance.

EViews Gareth
Fe ddaethom, fe welon, fe amcangyfrifon
Posts: 11378
Joined: Tue Sep 16, 2008 5:38 pm

Re: Duplicate year on graph axis

Postby EViews Gareth » Fri Sep 30, 2016 10:03 am

No attachments.
Follow us on Twitter @IHSEViews

fieldstream
Posts: 3
Joined: Fri Sep 30, 2016 7:59 am

Re: Duplicate year on graph axis

Postby fieldstream » Fri Sep 30, 2016 11:18 am

I created a graph of my data in EViews. On the x axis the graph repeated the first year (only). I set the graph to "label start of period" and that suppressed the duplicate first year.

However, when I copy the graph and paste to a Word file, the duplicate first year reappears. Clicking through its link back to Eviews and changing it does not remedy the problem. (attached).
graph w duplicate first year.doc
graph w duplicate first year.doc
(38.5 KiB) Downloaded 40 times



When I save the graph as an image (.jpg), there is no problem (attached).
ratiobondsgraph.jpg
ratiobondsgraph.jpg
ratiobondsgraph.jpg (44.37 KiB) Viewed 1273 times



Is there a way to get this to appear properly in Word directly from Eviews as OLE or emf, like the Eviews instructions say?

Thank you for your assistance.

EViews Jason
EViews Developer
Posts: 672
Joined: Tue Sep 16, 2008 3:50 pm

Re: Duplicate year on graph axis

Postby EViews Jason » Fri Sep 30, 2016 1:57 pm

Please send your workfile to support@eviews.com and refer to this thread.

EViews Katerina
Posts: 7
Joined: Thu Jun 25, 2015 9:54 am

Re: Duplicate year on graph axis

Postby EViews Katerina » Fri Sep 30, 2016 3:30 pm

If you want to try pasting your graph as an OLE object, after copying the graph from EViews, select the Paste Special button in Word, and then select Paste Link > As EViews Object.
After you paste the graph as a link, try to move the horizontal bar at the bottom of your graph in EViews (adjust the year range). On word you can right click on the graph and select update link. See if your graph changes to match EViews. Try again with your original year range selection.
Please let us know if you need help with pasting as OLE object.

fieldstream
Posts: 3
Joined: Fri Sep 30, 2016 7:59 am

Re: Duplicate year on graph axis

Postby fieldstream » Sat Oct 01, 2016 11:42 am

Thanks, but no luck. The graph x axis is already correct in EView when I copy and paste as link into Word. The first year is duplicated in how the graph appears in Word. I tried the click back through to EViews, but there is nothing to change inside EViews, the graph is fine there. Updating the link with the right click in Word doesn't change anything.
EDIT
Actually the problem is more persistent than I thought. When I am able to get the first year to not duplicate on the x axis, a later year (1836) duplicates instead.
Any suggestions you can offer are greatly appreciated.

EViews Jason
EViews Developer
Posts: 672
Joined: Tue Sep 16, 2008 3:50 pm

Re: Duplicate year on graph axis

Postby EViews Jason » Thu Oct 27, 2016 8:20 am

This should be fixed in the last patch. Please let us know otherwise


Return to “General Information and Tips and Tricks”

Who is online

Users browsing this forum: No registered users and 1 guest