Page 1 of 1

Problems with com server after 9.5 upgrade

Posted: Tue Feb 13, 2018 3:01 pm
by Michael Lewis
Hello, I recently loaded the eViews 9.5 Feb 8th 2018 update, and found that a python program which uses the COM server does not run. Specifically, the .Lookup method returns extra characters at the end of the list of series names. Also, the result of app.Get("=@pagefreq") contains extra trailing characters. The python package I am using is pyeviews.
Any insights?
Thank you very much,
Mike

Re: Problems with com server after 9.5 upgrade

Posted: Tue Feb 13, 2018 4:48 pm
by EViews Rebecca
Can you post the data and python commands you used?

Re: Problems with com server after 9.5 upgrade

Posted: Wed Feb 14, 2018 6:34 am
by Michael Lewis
A simple example is as follows:
import pyeviews as evp
eviewsapp = evp.GetEViewsApp(instance='either')
evp.Run('wfcreate temp_wf M 2000 2018',app=eviewsapp)
evp.Run('genr test = 1',app=eviewsapp)
evp.Run('genr test2 = 2', app= eviewsapp)

table = evp.GetWFAsPython(app=eviewsapp, wfname = "temp_wf")
Traceback (most recent call last):

File "<ipython-input-17-4386f8c6022f>", line 1, in <module>
table = evp.GetWFAsPython(app=eviewsapp, wfname = "temp_wf")

File "C:\Users\lewism\AppData\Local\Continuum\anaconda3\lib\site-packages\pyeviews\__init__.py", line 281, in GetWFAsPython
raise ValueError('Unsupported workfile frequency: ' + pgfreq)

ValueError: Unsupported workfile frequency: MB

If I run table = evp.GetWFAsPython(app=eviewsapp, wfname = "temp_wf") again I get a different error:

table = evp.GetWFAsPython(app=eviewsapp, wfname = "temp_wf")
Traceback (most recent call last):

File "<ipython-input-23-4386f8c6022f>", line 1, in <module>
table = evp.GetWFAsPython(app=eviewsapp, wfname = "temp_wf")

File "C:\Users\lewism\AppData\Local\Continuum\anaconda3\lib\site-packages\pyeviews\__init__.py", line 290, in GetWFAsPython
grp = app.GetGroup(snames_str, "@all");

COMError: (-2147024809, 'The parameter is incorrect.', ('TEST2E is not defined.', 'EViews.Application.9.EvaluateSeries', None, 0, None))

If I run table = evp.GetWFAsPython(app=eviewsapp, wfname = "temp_wf") again I may get no error or a different error.

Thanks

Mike

Re: Problems with com server after 9.5 upgrade

Posted: Wed Feb 14, 2018 9:04 am
by EViews Steve
Mike:

Thanks for the bug report. We found the problem and this will be fixed in the next 9.5 patch. We'll try to release it soon.

In the meantime, if you'd like to revert back to the previous version, you can download this previous patch and install it manually.
32-bit: http://cdn2.eviews.com/EViews9Patch_100617.exe
64-bit: http://cdn2.eviews.com/EViews9x64Patch_100617.exe

Steve

Re: Problems with com server after 9.5 upgrade

Posted: Wed Feb 14, 2018 2:59 pm
by EViews Steve
Ok we released a new patch for this. You won't detect it from within EViews 9 (unless you rolled it back to a previous patch), but you can manually download and install it from here or from our download page.

32-bit: http://cdn2.eviews.com/EViews9Patch_021418.exe
64-bit: http://cdn2.eviews.com/EViews9x64Patch_021418.exe

Steve

Re: Problems with com server after 9.5 upgrade

Posted: Tue Feb 20, 2018 11:43 am
by Michael Lewis
Thank you Steve, that fixes the problem.

Re: Problems with com server after 9.5 upgrade

Posted: Fri Aug 10, 2018 5:00 am
by DWEconData
I'm experiencing this same problem now with Eviews 10+, 64-bit, Standard Edition Oct 19 2017 build. Any suggestions/fixes? Thanks!

Re: Problems with com server after 9.5 upgrade

Posted: Fri Aug 10, 2018 6:09 am
by EViews Steve
Make sure you update to the latest version of EViews 10, there have been a few COM fixes since 10 was launched.