Running Kalman filter with initial data

For technical questions regarding estimation of single equations, systems, VARs, Factor analysis and State Space Models in EViews. General econometric questions and advice should go in the Econometric Discussions forum.

Moderators: EViews Gareth, EViews Moderator

king_luca
Posts: 22
Joined: Thu Aug 05, 2010 2:28 am

Re: Running Kalman filter with initial data

Postby king_luca » Fri Aug 06, 2010 10:32 am

I have 2 other, maybe silly, questions : are the results of the estimation for the coefficient c(1) to c(8) in percent ? and how can I constraint the coefficient c(1) to c(8) to be positiv ?

Thank you for all your help

startz
Non-normality and collinearity are NOT problems!
Posts: 3357
Joined: Wed Sep 17, 2008 2:25 pm

Re: Running Kalman filter with initial data

Postby startz » Fri Aug 06, 2010 10:38 am

king_luca wrote:I have 2 other, maybe silly, questions : are the results of the estimation for the coefficient c(1) to c(8) in percent ? and how can I constraint the coefficient c(1) to c(8) to be positiv ?

Thank you for all your help


The coefficients are just straight numbers, not percents.

The standard technique to get a positive result is to replace a coefficient with exp(coefficient). But you seem to have already done that, so it's unlikely that you want to further constrain the coefficients.

manthonisz
Posts: 6
Joined: Tue Nov 11, 2014 10:32 pm

Re: Running Kalman filter with initial data

Postby manthonisz » Thu May 03, 2018 12:25 am

Hello,

I have specified initial conditions also and was able to successfully run the state space equation once. However, when I tried to repeat the feat I got an error saying "Missing value found in state innovation vector." I'm not sure I consciously changed anything so would appreciate any thoughts as to what may have happened. Thanks guys!

Michael Anthonisz


Return to “Estimation”

Who is online

Users browsing this forum: No registered users and 5 guests