panel fully-modified OLS: AIC selects negative whitening lag

For technical questions regarding estimation of single equations, systems, VARs, Factor analysis and State Space Models in EViews. General econometric questions and advice should go in the Econometric Discussions forum.

Moderators: EViews Gareth, EViews Moderator

maragloria
Posts: 82
Joined: Tue Jun 29, 2010 7:09 am

panel fully-modified OLS: AIC selects negative whitening lag

Postby maragloria » Tue Aug 29, 2017 11:14 am

Hello,

I'm using EViews 9.5.

I'm using FM-OLS to estimate data in panel. When using information criteria such as AIC or BIC to select the whitenning lags, I'm getting:
"Long-run covariance estimates (Prewhitening with lags = -1 from AIC, maxlags = 4 ... )"

I find that strange, as if I try to use a negative lag manually, EViews do not allow it. What could the AIC/BIC negative selection mean?

Many thanks.

EViews Glenn
EViews Developer
Posts: 2548
Joined: Wed Oct 15, 2008 9:17 am

Re: panel fully-modified OLS: AIC selects negative whitening lag

Postby EViews Glenn » Tue Sep 05, 2017 11:12 am

I'm almost certain that it's just the reporting of the result that's wrong. If you post your workfile or send it to support@eviews.com with a link to this thread, we'll take a look.

EViews Glenn
EViews Developer
Posts: 2548
Joined: Wed Oct 15, 2008 9:17 am

Re: panel fully-modified OLS: AIC selects negative whitening lag

Postby EViews Glenn » Tue Sep 05, 2017 5:11 pm

As I suspected it's a display issue.

For the panel nonstationary regressions, (in cases where the lags/bandwidth are estimated from the data) the long-run covariances are estimated with individual specific lags/bandwidth. For these cases, there is obviously no single value that can be displayed in the top of the EViews output. The code which was supposed to sense this case and suppress the display of the selected result wasn't working properly for the lag selection case, so EViews was incorrectly displaying the test condition value.

We'll improve the display in the next patch.

maragloria
Posts: 82
Joined: Tue Jun 29, 2010 7:09 am

Re: panel fully-modified OLS: AIC selects negative whitening lag

Postby maragloria » Wed Sep 06, 2017 7:31 am

Thank you very much.
Just a follow-up question, if instead I use a fixed lag number, then the same number is used for each individual cross-section, right?

EViews Glenn
EViews Developer
Posts: 2548
Joined: Wed Oct 15, 2008 9:17 am

Re: panel fully-modified OLS: AIC selects negative whitening lag

Postby EViews Glenn » Wed Sep 06, 2017 3:02 pm

Yes


Return to “Estimation”

Who is online

Users browsing this forum: No registered users and 7 guests