DCCGARCH11

For questions about EViews Add-ins available from the EViews Add-ins webpage. Note each add-in available on our webpage will have its own individual thread.

Moderators: EViews Gareth, EViews Moderator, EViews Esther

miska
Posts: 2
Joined: Sun Jan 08, 2017 10:19 am

Re: DCCGARCH11

Postby miska » Mon Jan 09, 2017 12:58 am

Hello Trubador, could you please post a link to document (dcc model add in) again, I am not able to download it via existing link posted in forum. Thank you.

miska
Posts: 2
Joined: Sun Jan 08, 2017 10:19 am

Re: DCCGARCH11

Postby miska » Sun Jan 15, 2017 8:49 am

saadallah wrote:Hello,
I am using Eviews 9 and I keep getting this result "Optimization failed: unable to evaluate objective at optimization starting values." and my rhos are all "NA."

Could you please help?


Dear Trubador, I have the same problem. Could you please advise if the problem is with Eviews 9 amd add in compatibility or with our data settings.

Thank you

pdwhoward
Posts: 11
Joined: Tue Oct 23, 2012 2:44 pm

Re: DCCGARCH11

Postby pdwhoward » Fri Jul 07, 2017 5:38 pm

The latest Eviews 10 patch broke the functionality of this toolbox. When I try to run an estimation, now Eviews crashes. Does anyone else have this issue?

EViews Glenn
EViews Developer
Posts: 2555
Joined: Wed Oct 15, 2008 9:17 am

Re: DCCGARCH11

Postby EViews Glenn » Tue Jul 11, 2017 10:27 am

Could you provide data and clear instructions on how to replicate. That would help a great deal. Thanks.

izunna
Posts: 6
Joined: Sat Aug 05, 2017 4:28 am

Re: DCCGARCH11

Postby izunna » Sat Aug 05, 2017 11:41 pm

Hi,

I'm experiencing problem with DCCGARCH(1,1) add-in. I have install the DCCGARCH add-in to the add-in manager. However, any time I run the DCC(1,1) test, Eviews stops working. I'm using Eviews 9. Please does anyone have an idea of what I should do to get it running.

divac
Posts: 10
Joined: Sun Jan 30, 2011 4:36 pm

Re: DCCGARCH11

Postby divac » Mon Aug 07, 2017 1:32 am

izunna wrote:Hi,

I'm experiencing problem with DCCGARCH(1,1) add-in. I have install the DCCGARCH add-in to the add-in manager. However, any time I run the DCC(1,1) test, Eviews stops working. I'm using Eviews 9. Please does anyone have an idea of what I should do to get it running.


Any chance you are running AR(1) model for the mean or using any other regressors?

divac
Posts: 10
Joined: Sun Jan 30, 2011 4:36 pm

Re: DCCGARCH11

Postby divac » Mon Aug 07, 2017 1:52 am

I have a different problem with the add-in. I am trying to run a program with a large number of loops in Eviews 9.5. I've noticed that after 15 minutes of running a program file in the quiet mode Eviews shows an error message. One message was saying something like "!TODAY is not defined" and the second one was "%TYPE is invalid"...

It works fine for say 5-10 stocks (I started with 3 stocks and then increased it to 5 and then 10; all is estimated fine). So, I thought the loop works. However, once I increased the code to 50 stocks both runs it stopped on the correlation 307 or 308 or in about 15 minutes. It also works if I restart the loop from say a pair combination number 290. It just go through the 307th or 308th pair of stocks just fine until it breaks again in 15 minutes time or on the next 600th correlation or so.

Now I've tried it on my home PC. I've got "!TODAY is not defined" message on stocks pair number 126, after around 6 minutes. Can it be because I am using EViews via Jukebox, an app that my Uni supplies so everyone has a remote access to all programs purchased by the Uni? Also I have a Mac at home and I am using Parallels Desktop for Windows, while at Uni it is Windows 10 PC.

Can I somehow fix this? What happens if I increase the tolerance for errors? Now the program stops if one error comes up. Here is the code I am using (the data attached):

Code: Select all

'create empty equation to be used inside the loop
equation eq

'counter of how many equations we have run
!rowcounter=1

'step 1 (as if it is a 3-step procedure)
for !i=1 to 50
  !rowcounter = !i
  for !j=1 to 50
    if !i<>!j then
      equation eq{!i}.ls x{!i} c ar(1)
      eq{!i}.makeresid x{!i}r
    endif
  next
next

'company 1
for !i=2 to 50
  !rowcounter = !i
'  for !j=2 to 50
    if !i<>!j then
      group g1{!i} x1r x{!i}r
   g1{!i}.dccgarch11(unifit="GARCH",ctarget,correl,dccout,unigarch)
     endif
  next
'next

'company 2
for !i=3 to 50
 !rowcounter = !i
 ' for !j=3 to 50
    if !i<>!j then
      group g2{!i} x2r x{!i}r
      g2{!i}.dccgarch11(unifit="GARCH",ctarget,correl,dccout,unigarch)
endif
  next
'next

'company 3
for !i=4 to 50
 !rowcounter = !i
 ' for !j=4 to 50
    if !i<>!j then
      group g3{!i} x3r x{!i}r
      g3{!i}.dccgarch11(unifit="GARCH",ctarget,correl,dccout,unigarch)
endif
  next
'next

'company 4
for !i=5 to 50
 !rowcounter = !i
 ' for !j=5 to 50
    if !i<>!j then
      group g4{!i} x4r x{!i}r
      g4{!i}.dccgarch11(unifit="GARCH",ctarget,correl,dccout,unigarch)
endif
  next

izunna
Posts: 6
Joined: Sat Aug 05, 2017 4:28 am

Re: DCCGARCH11

Postby izunna » Mon Aug 07, 2017 3:49 am

divac wrote:
izunna wrote:Hi,

I'm experiencing problem with DCCGARCH(1,1) add-in. I have install the DCCGARCH add-in to the add-in manager. However, any time I run the DCC(1,1) test, Eviews stops working. I'm using Eviews 9. Please does anyone have an idea of what I should do to get it running.


Any chance you are running AR(1) model for the mean or using any other regressors?



Yes, I'm running an AR(1) with a regressor in the mean equation and a regressor in the variance equation. Please, what should I do?

izunna
Posts: 6
Joined: Sat Aug 05, 2017 4:28 am

Re: DCCGARCH11

Postby izunna » Mon Aug 07, 2017 4:26 am

divac wrote:
izunna wrote:Hi,

I'm experiencing problem with DCCGARCH(1,1) add-in. I have install the DCCGARCH add-in to the add-in manager. However, any time I run the DCC(1,1) test, Eviews stops working. I'm using Eviews 9. Please does anyone have an idea of what I should do to get it running.


Any chance you are running AR(1) model for the mean or using any other regressors?




I have attached the screen shot of the test and what happens when I click on Ok.
Attachments
Eviews screen.docx
(315.67 KiB) Downloaded 24 times

divac
Posts: 10
Joined: Sun Jan 30, 2011 4:36 pm

Re: DCCGARCH11

Postby divac » Mon Aug 07, 2017 7:05 am

izunna wrote:
divac wrote:
izunna wrote:Hi,

I'm experiencing problem with DCCGARCH(1,1) add-in. I have install the DCCGARCH add-in to the add-in manager. However, any time I run the DCC(1,1) test, Eviews stops working. I'm using Eviews 9. Please does anyone have an idea of what I should do to get it running.


Any chance you are running AR(1) model for the mean or using any other regressors?




I have attached the screen shot of the test and what happens when I click on Ok.


Ok, this is what has been discussed on here. The way I understood it is that you need to run your AR(1) model with other regressors before you use the add-in. You then use the residuals in the DCCGARCH11 add-in.

izunna
Posts: 6
Joined: Sat Aug 05, 2017 4:28 am

Re: DCCGARCH11

Postby izunna » Mon Aug 07, 2017 7:56 am

divac wrote:
izunna wrote:
divac wrote:
Any chance you are running AR(1) model for the mean or using any other regressors?




I have attached the screen shot of the test and what happens when I click on Ok.


Ok, this is what has been discussed on here. The way I understood it is that you need to run your AR(1) model with other regressors before you use the add-in. You then use the residuals in the DCCGARCH11 add-in.


Thanks for the information. I will try it and then get back to you asap

izunna
Posts: 6
Joined: Sat Aug 05, 2017 4:28 am

Re: DCCGARCH11

Postby izunna » Tue Aug 08, 2017 7:54 pm

divac wrote:
izunna wrote:
divac wrote:
Any chance you are running AR(1) model for the mean or using any other regressors?




I have attached the screen shot of the test and what happens when I click on Ok.


Ok, this is what has been discussed on here. The way I understood it is that you need to run your AR(1) model with other regressors before you use the add-in. You then use the residuals in the DCCGARCH11 add-in.


Please, I have tried to run the test following the suggestion you gave to me but I still experienced the same problem. I'm to quite sure if I was doing it the right way though. What I did was to run an AR(1) model for the each of the two variables and save their residuals. In the DCCGARCH(1,1) specification window, I entered the residuals as the return series and the number of lags in the mean equation I entered 1. Every other thing in the specification window is set as a default setting. Please any further clue as to what I should do. Thanks

izunna
Posts: 6
Joined: Sat Aug 05, 2017 4:28 am

Re: DCCGARCH11

Postby izunna » Thu Aug 10, 2017 2:44 am

Hi,

I'm experiencing some problems using add-in for DCCGARCH(1,1) in Eviews 9. The problem is whenever I run the DCCGARCH(1,1), the eviews stops working. Someone on this platform suggested that I should run the AR model separately and provide the residuals as inputs for the return series in the DCC add-in. I have done that but the problem still persist. Please if there is anyone who have encountered this type of problem before and Knows exactly what I should do, kindly assist me. You also contact me via my email at anyikwaizunna2000@yahoo.com.


Return to “Add-in Support”

Who is online

Users browsing this forum: No registered users and 7 guests