Bayesian model averaging

For questions about EViews Add-ins available from the EViews Add-ins webpage. Note each add-in available on our webpage will have its own individual thread.

Moderators: EViews Gareth, EViews Moderator, EViews Esther

EViews Esther
EViews Developer
Posts: 149
Joined: Fri Sep 03, 2010 7:57 am

Bayesian model averaging

Postby EViews Esther » Thu Apr 05, 2012 2:45 pm

This thread is about the BMA add-in which accounts for model uncertainty associated with variable selection.

ESoliman
Posts: 2
Joined: Sun Aug 25, 2013 9:47 pm

Re: Bayesian model averaging

Postby ESoliman » Sun Aug 25, 2013 10:43 pm

Hi, I'm trying to use the BMA EViews add-in for model averaging (already used the R counterpart package successfully). Also went through some pages of the Command Reference (pp. 154 onwards) on the requirements to properly run the BMA add-in. I think I've checked all necessities already (rscproxy, statconnDCOM, and R). Couldn't 'sync' it though, for example when I tried the StatConnector Test the error "Method ~ of object '~' failed" kept on showing itself.

Also tried to use a version of RandFriends that I found for an easier install. I thought the bma() EViews function would already work but after a little waiting time a different error popped-up ("R (for bma<-bic.glm(x,...) returned an error; evaluation stopped because of an error"). Could you give some specific recommendations for BMA to work properly in EViews? Thank you.

EViews Gareth
Fe ddaethom, fe welon, fe amcangyfrifon
Posts: 11260
Joined: Tue Sep 16, 2008 5:38 pm

Re: Bayesian model averaging

Postby EViews Gareth » Sun Aug 25, 2013 11:14 pm

Sounds like you got it working, it just doesn't work on your particular data.
Follow us on Twitter @IHSEViews

ESoliman
Posts: 2
Joined: Sun Aug 25, 2013 9:47 pm

Re: Bayesian model averaging

Postby ESoliman » Wed Aug 28, 2013 12:40 am

Hi Gareth. I tried a different EViews workfile, a simple one with 74 time series observations with 15 variables. Utilized the needed commands (e.g. xopen()) to maintain the connection to make sure. My target was to regress a response variable on the rest of the series. The required window appeared after clicking "Add-ins" >>> "BMA for GLM/LM". However after writing the series names on the pertinent box and pressing "OK", the error "R (for 'temp_EViews_depvar') returned an error; internal error: unsupported data format passed to interpreter." popped up.

Tried it using the "bma(method=LM ..." technique as well but I'm getting the same error. Can you advise on a possible workaround to this issue? Is it still possible to execute bayesian model averaging using the BMA add-in despite this?

Thanks,
Edward

Jamel Saadaoui
Posts: 2
Joined: Thu Sep 12, 2013 10:35 am

Re: Bayesian model averaging

Postby Jamel Saadaoui » Thu Sep 12, 2013 10:41 am

Dear Sir,

I have some trouble when I try to use the BMA add-in with Eviews.

When I try to run a regression, Eviews send me an error message "StatConnectorSrv.StatConnector is not connected".

I downloaded the latest version of R and of the BMA package.

Thank you for your help,

Jamel

EViews Gareth
Fe ddaethom, fe welon, fe amcangyfrifon
Posts: 11260
Joined: Tue Sep 16, 2008 5:38 pm

Re: Bayesian model averaging

Postby EViews Gareth » Thu Sep 12, 2013 11:01 am

You need to get statconnector working properly. Follow the instructions for installing RExcel here:
http://homepage.univie.ac.at/erich.neuw ... to_install
Follow us on Twitter @IHSEViews

Jamel Saadaoui
Posts: 2
Joined: Thu Sep 12, 2013 10:35 am

Re: Bayesian model averaging

Postby Jamel Saadaoui » Thu Sep 12, 2013 11:39 am

Thank you very much for your help, now it's work perfectly with some data downloaded thanks to getmacrodata add-in.

Jamel

uwhusky
Posts: 4
Joined: Mon May 06, 2013 10:37 pm

Re: Bayesian model averaging

Postby uwhusky » Tue Oct 14, 2014 12:33 am

Hi,

When I tried to run the BMA add-in in EViews 8, EViews prompts me the error message "No external connection is open." Any clues why this message is shown, and how to resolve this problem? Thanks.

EViews Gareth
Fe ddaethom, fe welon, fe amcangyfrifon
Posts: 11260
Joined: Tue Sep 16, 2008 5:38 pm

Re: Bayesian model averaging

Postby EViews Gareth » Tue Oct 14, 2014 8:17 am

Do you have R properly installed and working?
Follow us on Twitter @IHSEViews

Geo
Posts: 1
Joined: Thu Mar 09, 2017 12:50 pm

Re: Bayesian model averaging

Postby Geo » Thu Mar 09, 2017 12:57 pm

Hi everybody (I hope that someone will see this post!)

When I am trying to run BMA the following message appears: "StatConnectorSrv.StatConnector is not registered".

I have downloaded all the necessary libraries in R.

I tried to use the linked suggested before (http://homepage.univie.ac.at/erich.neuw ... to_install),
but I got totally lost!

Any ideas?
Thanks.


Return to “Add-in Support”

Who is online

Users browsing this forum: No registered users and 1 guest