prog. runs ok on v7.2 not on 9.5

For posts that don't quite fit into any of the other forums, including posts about these forums themselves.

Moderators: EViews Gareth, EViews Moderator

vogelh
Posts: 28
Joined: Mon May 21, 2012 2:27 pm

prog. runs ok on v7.2 not on 9.5

Postby vogelh » Tue May 17, 2016 2:41 pm

Hi Gareth,
I just upgraded from version 7.2 to 9.5 on my 32-bit machine. My major program runs fine with no error messages on 7.2, but it gives an error message on filling one of my matrix cells with N/A.

The message is " Non numeric argument in "RESULTS(2,19)=OUTCOME(14,2)"

Was wondering if you have a theory about why this is happening and any suggestions to fix.

Thanks.

EViews Glenn
EViews Developer
Posts: 2555
Joined: Wed Oct 15, 2008 9:17 am

Re: prog. runs ok on v7.2 not on 9.5

Postby EViews Glenn » Tue May 17, 2016 3:08 pm

Difficult to say without seeing the program and the data.

vogelh
Posts: 28
Joined: Mon May 21, 2012 2:27 pm

Re: prog. runs ok on v7.2 not on 9.5

Postby vogelh » Tue May 17, 2016 4:14 pm

there's no change in data or program from v7.2 to v9.5.
Was there a change in how Eviews processes instructions or in underlying code? Just wondering.

EViews Glenn
EViews Developer
Posts: 2555
Joined: Wed Oct 15, 2008 9:17 am

Re: prog. runs ok on v7.2 not on 9.5

Postby EViews Glenn » Tue May 17, 2016 4:22 pm

There are always changes in underlying routines as we add additional features. For example, estimation of ARMA models in EViews now defaults to ML instead of CLS. But we try to minimize the number of these changes and generally won't make changes that will cause different behavior unless there is a good reason.

That said, it's impossible to know what may be causing your issue without seeing the program and data.

vogelh
Posts: 28
Joined: Mon May 21, 2012 2:27 pm

Re: prog. runs ok on v7.2 not on 9.5

Postby vogelh » Tue May 17, 2016 10:16 pm

Hi Prof. Sueyoshi,

I see you every year at the January economics conference.

I suspect that there was a change in Eviews 9.5 that handles matrix data transfer calculations.
As you had suggested above that it's impossible to know anything about the error message without seeing the program,
I'm wondering if I might send the program directly to you and then you can see that there's no error with v7.2, but there is with v.9.5.
The data file is exactly the same for both.
Thanks.

EViews Glenn
EViews Developer
Posts: 2555
Joined: Wed Oct 15, 2008 9:17 am

Re: prog. runs ok on v7.2 not on 9.5

Postby EViews Glenn » Wed May 18, 2016 9:35 am

You can send to support@eviews.com and we'll have someone look at it.
Or if you post it here we can take a look.


Return to “Any Other Business”

Who is online

Users browsing this forum: No registered users and 1 guest