Page 1 of 1

add factors

Posted: Mon Dec 12, 2016 2:50 am
by tvonbrasch
Hi

I am trying to initialise add factors so that all equations in the model have no residual when evaluated at actuals:

Code: Select all

smpl @all
_kvarts.addassign(i) @all 

smpl 2016 2020
_kvarts.addinit(v=n) @all    


but this yields the following error message:

add_factors_overflow.JPG
add_factors_overflow.JPG (39.34 KiB) Viewed 3479 times


Is there something I am doing wrong?

THomas

Re: add factors

Posted: Mon Dec 12, 2016 10:02 am
by EViews Gareth
EViews just can't create the add-factors, you're doing every thing correctly.

I would guess it might be a data scaling issue - you might need to rescale the data.

Re: add factors

Posted: Tue Dec 13, 2016 1:11 am
by tvonbrasch
Hi Gareth

Thanks for your reply.

Can you provide me with a clue on how to proceed?

I cannot just divide variables by a scalar as the intepretation of the equations would change. Would a rescaling require a re-estimation of all the equations? Or is there another way of doing this?

The model object consists currently of only text objects which makes the job of re-estimating much more time consuming.

Is re-scaling something that could be build into the optimizer in Eviews? (ideally, an Eviews user should not have to think about this issue)
Thomas

Re: add factors

Posted: Tue Dec 13, 2016 8:54 am
by EViews Gareth
You'd have to scale the variables, reestimate the equations and then recompile the model - painful I'm afraid.

Re: add factors

Posted: Tue Dec 13, 2016 8:55 am
by EViews Gareth
Although I should point out that I ran the prg you provided above on the kvarts workfile you previously provided, and it worked without any errors.

Re: add factors

Posted: Tue Jul 04, 2017 7:12 am
by tdeco
Hello,

I have a similar issue I am hoping someone could help me with.
I assign and initialize my add factors as a variable shift add factor. See below. Everything seems to work out fine when I run my program.

smpl @all
_model.addassign(v) @all

smpl 2016 2020
_model.addinit(v=n) @all

However, when I decide to assign my add factors as an intercept shift, for some of my variables (not all), i too get an overflow message. How is it that I can solve for one type (variable shift) but not another (intercept shift) which I would think would be easier. Is there a possible solution to this issue. I dread to undertake the painful approach offered below. :(

Thank you.