Solver has stalled

For technical support, tips and tricks, suggestions, or any other information regarding the EViews model object.

Moderators: EViews Gareth, EViews Moderator

Posts: 434
Joined: Fri Apr 15, 2011 5:35 am

Solver has stalled

Postby tvonbrasch » Fri Jan 08, 2016 3:22 am

Hi again

This adds on to the post viewtopic.php?f=10&t=13749.
I have stripped down the model in viewtopic.php?f=10&t=13749. so it now only consists of 7 equations.

When running the model in the attached workfile I get the error message:
Solve terminated - Solver has stalled: starting values may be too far from a solution

The block structure of the model looks like this:
Number of equations: 7
Number of independent blocks: 2
Number of simultaneous blocks: 1
Number of recursive blocks: 1

Block 1: 1 Recursive Equations


Block 2: 6 Simultaneous Equations (2 feedback vars)
bh11(6) bh92s(4) di89(5) bh43(1) bh91s(2) di11(3)

Interestingly If you remove Block 1 from the model Eviews has no problems with solving the model. Block 1 consists of the equation
0 * pM92C + pv92S = (m92u * pM92U + m92c * pM92C + pE92S * e92S + pFT92S * ft92S + pF92S * f92S) / x92S + zlw92S * w92S / 1000

This equation does not depend on any of the variables in Block 2, so why is it suddenly a problem for Eviews to solve the model when this equation is included? (as I showed in viewtopic.php?f=10&t=13749, TROLL solves this model without difficulty). There must be an error somewhere.

I have tried to reduce the model as much as possible so that you can take a look and try to find what is causing this error.

(108.61 KiB) Downloaded 271 times

Posts: 1
Joined: Tue Jul 18, 2017 5:53 am

Re: Solver has stalled

Postby ElsaP » Tue Jul 18, 2017 6:06 am


I actually have the same problem. I am working on an improvement of a part of my model written in EViews and am defining some new variables. I just wrote a new line and it will give me "solver has stalled [...]" but when I don't include this line, the model is able to be solved and when I do the maths of the new variable I am trying to define, it works.
It can't be that I miswrote it since the model runs until 2020 (instead of 2050).
Have you found any explanation to your problem ?
(I am seriously starting to get crazy)


Posts: 434
Joined: Fri Apr 15, 2011 5:35 am

Re: Solver has stalled

Postby tvonbrasch » Tue Jul 18, 2017 1:30 pm

Hi Elsa,

sorry, i did not find the answer. You should upload your workfile to the Eviews team and let them try to figure out what is causing the problem

Return to “Models”

Who is online

Users browsing this forum: No registered users and 3 guests