Model generating NA values

For technical support, tips and tricks, suggestions, or any other information regarding the EViews model object.

Moderators: EViews Gareth, EViews Moderator, EViews Chris

Tom_Crane
Posts: 1
Joined: Wed May 14, 2014 1:33 am

Model generating NA values

Postby Tom_Crane » Wed May 14, 2014 1:47 am

Hi there,

I've recently been given a new work laptop, on which I've installed eviews and continued working with a database and model our company built a few years ago in eviews. The exact same file and model and solving method as I'm using works fine on my colleague's new machine, but when I hit solve on the model it comes up NA generated for each time period and each variable (of which there are 288).

I'm having this problem on both eviews 6 and with a demo version of eviews 8, so could it potentially be something to do with my computer's settings?

Any help would be much appreciated.

Regards,

Tom

EViews Glenn
EViews Developer
Posts: 2539
Joined: Wed Oct 15, 2008 9:17 am

Re: Model generating NA values

Postby EViews Glenn » Thu May 15, 2014 7:10 am

Tom, is there any chance we can see the workfile? It's hard to say without seeing the model and data.

aroncaglia
Posts: 4
Joined: Fri Jan 01, 2016 8:26 am

Re: Model generating NA values

Postby aroncaglia » Fri Jan 01, 2016 8:32 am

Hey there,

I have been facing the exact same problem as Tom has. I have created values for each of the exogenous variables used in a 3-equation model in order to perform dynamic solutions and endogenous forecasts, but seem to fail whenever I try to extend the forecasting sample to out-of-sample range. What was the problem with Tom's solution above?

Or, even, should I send you my work file so you could take a look at what I have been doing wrong?

Thanks a lot.

André

EViews Gareth
Fe ddaethom, fe welon, fe amcangyfrifon
Posts: 11299
Joined: Tue Sep 16, 2008 5:38 pm

Re: Model generating NA values

Postby EViews Gareth » Fri Jan 01, 2016 11:49 am

Every case is different. We'll need to see the workfile
Follow us on Twitter @IHSEViews

aroncaglia
Posts: 4
Joined: Fri Jan 01, 2016 8:26 am

Re: Model generating NA values

Postby aroncaglia » Fri Jan 01, 2016 1:02 pm

I tried to send you the work file through a private message, but the website does not allow for wf1 extension. How should I procede?

aroncaglia
Posts: 4
Joined: Fri Jan 01, 2016 8:26 am

Re: Model generating NA values

Postby aroncaglia » Fri Jan 01, 2016 1:05 pm

You can run either model for a endogenous forecasting to see the problem I have mentioned. How should I send the file? It states that extensions wf1 are not allowed.
Last edited by aroncaglia on Fri Jan 01, 2016 6:03 pm, edited 1 time in total.

EViews Gareth
Fe ddaethom, fe welon, fe amcangyfrifon
Posts: 11299
Joined: Tue Sep 16, 2008 5:38 pm

Re: Model generating NA values

Postby EViews Gareth » Fri Jan 01, 2016 4:55 pm

The variable d_2001q3, which is an exogenous variable, has no values over the solution sample.
Follow us on Twitter @IHSEViews

aroncaglia
Posts: 4
Joined: Fri Jan 01, 2016 8:26 am

Re: Model generating NA values

Postby aroncaglia » Fri Jan 01, 2016 6:13 pm

Thank you very much. It all works fine now. Have a great year!


Return to “Models”

Who is online

Users browsing this forum: No registered users and 1 guest