Licensing Eview 9 silent install

For questions regarding installation and registration of EViews.

Moderators: EViews Gareth, EViews Steve, EViews Jason, EViews Moderator

aspaterson
Posts: 2
Joined: Fri Apr 24, 2015 3:21 am

Licensing Eview 9 silent install

Postby aspaterson » Fri Apr 24, 2015 3:58 am

I am looking to run a silent install of Eviews 9 to approximately 200 of our lab machines. I have followed the guide from http://forums.eviews.com/viewtopic.php?f=1&t=21 on creating the setup.iss file, and have been trying to manually install it before bringing SCCM into the equation.

We have a license server up and running, and this has been tested with standalone installs.

Though the silent install works fine, when launching the software I get an error that the license can not be found and the input server/port etc. This information should have been recorded in the -r install, and when checking the setup.iss I can see that the relevant serial number and cloning key is in the file.

The command line I am using is EViews9Installer.exe -s -f1c:\data\setup.iss

Can anyone offer a suggestion as to why this is happening? We recall a similar issue with Eviews 7 which we circumvented by using the command line Setup.exe -s -f1 but leaving the setup.iss in the INSTALL folder. However, our Eviews 9 installer only has a single EViews9Installer.exe file and does not work using that method either.

EViews Jason
EViews Developer
Posts: 662
Joined: Tue Sep 16, 2008 3:50 pm

Re: Licensing Eview 9 silent install

Postby EViews Jason » Fri Apr 24, 2015 7:29 am

What is the exact error message? Please post a screenshot of the error.

Without seeing the message, it sounds like you haven't added the license to your license manager.

To do so, start the EViews license management console. Next select local server->licenses.

Is your license listed in the right window pane?

If it is not listed, press the right mouse button while over local server->licenses and select ‘add license’. In the dialog, enter the rest of the requested information and press ‘register now’. Next try starting the EViews application.

aspaterson
Posts: 2
Joined: Fri Apr 24, 2015 3:21 am

Re: Licensing Eview 9 silent install

Postby aspaterson » Fri Apr 24, 2015 7:53 am

Hi, the license is definitely in the license manager as I have run a manual non-silent install using the serial and clone key, and it shows as a license in the LM. We have 2 licenses active, one for 7 and one for 9, and I can see a license getting accepted into the LM when I run the software.

As i've already licensed it manually on my machine now, i've just run the silent install on another test box and the software has installed and licensed fine! So without changing anything, it now appears to be working.

I guess this is case closed :D Thanks


Return to “Installation and Registration”

Who is online

Users browsing this forum: No registered users and 2 guests